kz1300 banner

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Tachometer not responsive 1 week 6 days ago #30055

  • Badger
  • Badger's Avatar Topic Author
  • Offline
  • Sustaining Member
  • Sustaining Member
  • Posts: 28
  • Thank you received: 0
Had problems with the 1981 speedometer cluster after taking a spill a few months back. After installing the tachometer it became slow to respond to engine revs. Reads about right at an idle but wont respond to throttle revs. Any and all advice is welcome in advance.
Happy New Year to all.

Please Log in or Create an account to join the conversation.

Tachometer not responsive 1 week 6 days ago #30056

  • scotch
  • scotch's Avatar
  • Offline
  • Sustaining Member
  • Sustaining Member
  • Posts: 1727
  • Thank you received: 717
Sorry to hear about your "spill".

Don't know how bad this "spill" was.......doubtful that the tach. frame got damaged, so would focus on giving the internals a good cleaning. Old lube, dust and insects will cause this scenario.
  DO NOT use high pressure air !  You'll ruin the Hair-spring" !
  Electronic Cleaner in an aerosol can and WITH and Extension Tube  is effective and safer as you can precisely control it's application..  The only lube required would be a drop of oil on the input bushing.  Don't lube anything else !   (This applies to the Speedo in particular) .  When clean, there is no load on any of the internals. Over lubing will just attract dust and grime.
hope this works out for you !
1980 KZ 1300 sr# KZT30A-009997
Always High - Know Fear !
The following user(s) said Thank You: dcarver220b

Please Log in or Create an account to join the conversation.

Tachometer not responsive 5 days 15 hours ago #30063

  • dcarver220b
  • dcarver220b's Avatar
  • Offline
  • Sustaining Member
  • Sustaining Member
  • Posts: 308
  • Thank you received: 66
I've used these guys 2x times for kz1300 speedo's and 1x for Honda Accord speedo. They do great work, and do tachometers too.

www.foreignspeedoinc.com

 

Please Log in or Create an account to join the conversation.

Tachometer not responsive 4 days 11 hours ago #30065

  • Gavin
  • Gavin's Avatar
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 81
  • Thank you received: 15
I would try a new cable first off, the ends are squared to fit the drive if rounded off with use the cable can slip
when under excessive load

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.052 seconds
Powered by Kunena Forum